Sciencemadness Discussion Board

New FTP server in testing mode

MadHatter - 25-1-2020 at 19:45

The FTP is online and once again I'm
starting from scratch. This is the
testing phase for download/upload.

This FTP is run using FileZilla Server(v0.9.60.2).
I strongly recommend the use of FileZilla Client

Instructions for the client here: Attachment: FZCv3.46.3.txt (2kB)
This file has been downloaded 514 times

There is some information in some LIBRARY
folders namely:


Folders LIBRARY and NOTICES are

self-explanatory and can be read or
written at will.

ALL users are logged into the PUBLIC
area. Users are encouraged to download
and upload. User folders can be created
in the PUBLIC area. Caveat emptor -
anything in the PUBLIC area can be
deleted or overwritten by ANY user.
Please be respectful of your fellow
madscientists !


1) Server will be backed up everyday
2) PORN not allowed. There's plenty
of that on the internet.
3) MUSIC and MOVIES not allowed. I
don't want to receive a DMCA notice.
Exception: Instructional videos

Violations of policies 2 and 3 will
result in removal of such material
WITHOUT notice. Users who are
administrators or moderators may remove
offending material at their discretion.

After the testing phase, which will last until
all bugs are resolved, I will setup accounts.
Please U2U me with a request for an account
and supply the desired username/password. I'll
let you know when testing is complete and the
access information will be removed. Any material
uploaded to that point will be retained.

Report any bugs to this thread or a U2U to me.

Enjoy !

Testing access information:

Username: user
Password: userpw(will show as 6 dots during entry)
Port: 5000(my ISP blocks standard FTP port 21)

Polverone, please check your U2U.

stoichiometric_steve - 26-1-2020 at 04:53


[Edited on 26-1-2020 by stoichiometric_steve]

Roguesci archive

MadHatter - 11-3-2020 at 21:19

In case anyone is interested, there is subcategory on
the FTP for roguesci. It's in an uncompressed file format
and listed under the LIBRARY section. It contains 9666
.html files and roughly 107MB. Easy enough to download.

CouchHatter - 12-3-2020 at 13:45

Glad to hear this! I have searched the forum for some books, and thought I missed out. Why start from scratch?

Starting from scratch

MadHatter - 24-7-2020 at 11:24

This is the 3rd incarnation of the FTP.
Issues in the past have included loss of
internet service and 1 time, self-destruction
of the external drive(MAXTOR in this case)
and theft of an external drive.

I back it up every day onto a 1 TB Western
Digital drive. I'll never go back to MAXTOR.

There seems to be little interest so it will
remain wide open in case anybody wants
to look at it. My deepest apologies for the
problems of the past. My situation is
extremely stable now being retired and not
having to worry about theft or finances.

After the state of Maryland starts sending my
pension(already on Social Security) I would
like to start donating items from eBay. More
senior members will remember me doing this
with some items in the past. For example:
medical centrifuge, a bizarre looking flask,
battery charger, etc.

I'll let members know when this happens as
my laboratory needs are quite simple and it
would be ashame to let good eBay deals get
passed up. As for shipping I'll ship anywhere.
Already shipped to U.S., Canada, U.K. and Sweden.
So there it is. Knowledge should always be
free and I'm happy to help with some more
lab gear to that end. NEVER GIVE UP FOLKS !

I'm open to suggestions for lab gear. COVID-19
is helping to delay my pension. Put ideas in this
thread or a U2U. Anything within reason.

[Edited on 2020/7/24 by MadHatter]

Syn the Sizer - 24-7-2020 at 13:44

Are the host name, user name and password still the same as the original post?

FTP Login

MadHatter - 24-7-2020 at 17:37

Yes. And I still recommend the FileZilla FTP
client for connecting as it's the most
compatible with the server.

Pumukli - 27-7-2020 at 05:32

Timed out. Is the server running?

Timed Out

MadHatter - 27-7-2020 at 05:54

Yes, the server is running. I just checked it.

Pumukli - 27-7-2020 at 12:09

OK, name resolution is ok, server accepts uname/password, but gives error 550, home directory doesn't exist and quits.

Edit: Btw. filezilla's own test server seems to be working.

[Edited on 28-7-2020 by Pumukli]

Housane - 28-7-2020 at 00:40

Command: PASS ******
Response: 550 Home directory does not exist
Error: Critical error: Could not connect to server

Seems to be a bug? The test wizard returned fine


MadHatter - 28-7-2020 at 07:40

There seems to be a problem in that
the server is behind a NAT router. I've
been exploring options to get around
this. All the permissions are set for
the PUBLIC directory so it has to be
something else. I'll post back when I
find a solution.

Pumukli - 28-7-2020 at 08:28

This may help solving the problem:

Housane - 13-8-2020 at 08:52

Has this been fixed yet?

Marvin - 20-8-2020 at 08:25

I saw a login prompt today for the first time in several months, but I get the same error as others.

A google suggests this may be fixed by going to EDIT - USERS - SHARED FOLDERS

And I assume also making sure the program has permissions on the folder.

FTP problems

MadHatter - 20-8-2020 at 15:30

I'm still trying to debug this damn thing.
This is the 1st time behind a router.
BTW, the password for the account "user"
has been turned off(not required). Please
report back any other problems including
the error #. Any suggestions from anyone
experienced with FileZilla Server would be
greatly appreciated.

BromicAcid - 20-8-2020 at 19:26

You certainly live up to your name MadHatter, how long have you been making incarnations of an FTP? Seems like more than a decade. I still have my old login information in a notebook around here for the first incarnation (just ran across it the other day). Thanks for keeping the torch burning.


MadHatter - 21-8-2020 at 08:25

Right now most information on the FTP
will be under LIBRARY/REFERENCE.
Apparently some people have been able
to login. Remember the most compatible
client is FileZilla.

Housane - 27-8-2020 at 13:31

I get directory listing failed error below

Command: PORT 86,142,17,88,23,122
Response: 200 Port command successful
Command: MLSD
Response: 150 Opening data channel for directory listing of "/"
Response: 425 Can't open data connection for transfer of "/"
Error: Failed to retrieve directory listing

FTP Problems

MadHatter - 27-8-2020 at 15:06

Continuing debugging FileZilla Server.
Opening up as much as possible on
router. Remember:

USERID: user
PORT: 5000

Do not enter a password.

Keep sending error reports when
you run into them.

Still recommend FileZilla client:

Pumukli - 28-8-2020 at 00:32


The link I posted a few weeks ago suggests that there are intricate permission rules at different points in the server's setup what you must set right in order to get it working... Unfortunately the process is not straightforward "click and forget".
Opening up as much as on the router won't help because it is not a problem on the router. We can actually reach your server from the other side of the globe, we can get through your router but those server misconfigurations prevent us from getting to the content.

Housane - 30-8-2020 at 10:25

Same error as before

Status: Resolving address of
Status: Connecting to
Status: Connection established, waiting for welcome message...
Status: Insecure server, it does not support FTP over TLS.
Status: Logged in
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/" is current directory.
Command: TYPE I
Response: 200 Type set to I
Command: PORT 86,142,17,88,23,120
Response: 200 Port command successful
Command: MLSD
Response: 150 Opening data channel for directory listing of "/"
Response: 425 Can't open data connection for transfer of "/"
Error: Failed to retrieve directory listing

Port change

MadHatter - 31-8-2020 at 10:15

Change the port to 21. For some reason
FileZilla attempts to use my LAN address
with 5000. Please report any errors here.
Note: On AUGUST 27, 2020 someone did
successfully download according to the

dennisfrancisblewettiii - 7-10-2021 at 05:39

Is this thread out of date?

Ping done on October 7th, 2021 at approximately 8:36 a.m. Central Time (Wisconsin, USA).


Pinging [] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

Ping done approximately 8:40 a.m..


Pinging [] with 32 bytes of data:
Reply from bytes=32 time=14ms TTL=59
Reply from bytes=32 time=14ms TTL=59
Reply from bytes=32 time=14ms TTL=59
Reply from bytes=32 time=14ms TTL=59

Ping statistics for
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 14ms, Maximum = 14ms, Average = 14ms

[Edited on 7-10-2021 by dennisfrancisblewettiii]