Sciencemadness Discussion Board
Not logged in [Login ]
Go To Bottom

Printable Version  
Author: Subject: Problem attaching gif file image
Ritter
National Hazard
****




Posts: 370
Registered: 20-6-2008
Location: Earth
Member Is Offline

Mood: Curious

[*] posted on 24-7-2008 at 07:38
Problem attaching gif file image


I have not previously encountered problems with attaching gif image files to posts. But today I am getting this error message after each of multiple tries:

Quote:
MySQL has encountered an unknown error. To find out the exact problem, please set the DEBUG flag to true in config.php.


This problem would appear to be in a setting in the board server.




Ritter
=============================
\"The production of too many useful things results in too many useless people.\"

Karl Marx
View user's profile View All Posts By User
Sauron
International Hazard
*****




Posts: 5351
Registered: 22-12-2006
Location: Barad-Dur, Mordor
Member Is Offline

Mood: metastable

[*] posted on 24-7-2008 at 09:11


Does same error occur with jpg files?



Sic gorgeamus a los subjectatus nunc.
View user's profile View All Posts By User
Ritter
National Hazard
****




Posts: 370
Registered: 20-6-2008
Location: Earth
Member Is Offline

Mood: Curious

[*] posted on 24-7-2008 at 10:10


Quote:
Originally posted by Sauron
Does same error occur with jpg files?


I can't save a cdx file as a jpg, only as a gif. But the same error message is returned when I attempt to upload the parent cdx. Usually cdx files upload just as easily as gifs.

This gif file is 10.5 kb (692x366 pixels).

Earlier I created a test post & uploaded that arsine gif from the other day & it worked fine. That one is 16.5 kb (804x570 pixels).

I tried uploading it as a tif & that didn't work. Shortening the file name didn't work either.

I'm in communication with Polverone to see if some setting in the server needs to be checked.

[Edited on 24-7-2008 by Ritter]




Ritter
=============================
\"The production of too many useful things results in too many useless people.\"

Karl Marx
View user's profile View All Posts By User
Polverone
Now celebrating 18 years of madness
*********




Posts: 3164
Registered: 19-5-2002
Location: The Sunny Pacific Northwest
Member Is Offline

Mood: Waiting for spring

[*] posted on 24-7-2008 at 10:47


What is the file name? XMB has had some odd reactions to file names that contain certain strings.



PGP Key and corresponding e-mail address
View user's profile Visit user's homepage View All Posts By User
Ritter
National Hazard
****




Posts: 370
Registered: 20-6-2008
Location: Earth
Member Is Offline

Mood: Curious

[*] posted on 24-7-2008 at 12:36


Quote:
Originally posted by Polverone
What is the file name? XMB has had some odd reactions to file names that contain certain strings.


I've tried the following:

1,1'-dinitro.gif
1,1'-dinitro-3,3'-azo-1,2,4-triazole.gif
1,1'-dinitro-3,3'-azo-1,2,4-triazole.tif
1,1'-dinitro-3,3'-azo-1,2,4-triazole.bmp

Because XMB may not care for elements of those strings, I uploaded it simple as 'A.gif,' which uploaded with no problem.

Thanks, Polverone!

[Edited on 24-7-2008 by Ritter]




Ritter
=============================
\"The production of too many useful things results in too many useless people.\"

Karl Marx
View user's profile View All Posts By User
-jeffB
Hazard to Others
***




Posts: 185
Registered: 6-12-2007
Member Is Offline

Mood: No Mood

[*] posted on 24-7-2008 at 16:20


Quote:
Originally posted by Ritter
I've tried the following:

1,1'-dinitro.gif
1,1'-dinitro-3,3'-azo-1,2,4-triazole.gif
1,1'-dinitro-3,3'-azo-1,2,4-triazole.tif
1,1'-dinitro-3,3'-azo-1,2,4-triazole.bmp



Ugh. Speaking as a programmer, filenames with embedded single quotes (') will kill all sorts of things. Commas aren't great, either. You can write your software in such a way that they work, but most people don't bother.
View user's profile View All Posts By User
not_important
International Hazard
*****




Posts: 3873
Registered: 21-7-2006
Member Is Offline

Mood: No Mood

[*] posted on 24-7-2008 at 17:17


Agree - I suspect the quote marks are the problem. Punctuation is always iffy on strings going into a database unless you _know_ the software is converting them to escape sequences.
View user's profile View All Posts By User
Ritter
National Hazard
****




Posts: 370
Registered: 20-6-2008
Location: Earth
Member Is Offline

Mood: Curious

[*] posted on 24-7-2008 at 19:04


Quote:
Originally posted by not_important
Agree - I suspect the quote marks are the problem. Punctuation is always iffy on strings going into a database unless you _know_ the software is converting them to escape sequences.


Problem fixed. Thanks!




Ritter
=============================
\"The production of too many useful things results in too many useless people.\"

Karl Marx
View user's profile View All Posts By User
JohnWW
International Hazard
*****




Posts: 2849
Registered: 27-7-2004
Location: New Zealand
Member Is Offline

Mood: No Mood

[*] posted on 21-12-2008 at 02:05


I have found today that, again, it is not possible to post image attachments to messages, even after repeated attempts with changes in the file-name. From the error message received, it is due to a software error in MySQL, in the file config.php, and can be corrected by settimg DEBUG to "true". One of the moderators please see about fixing this.

[Edited on 21-12-08 by JohnWW]
View user's profile View All Posts By User
Sauron
International Hazard
*****




Posts: 5351
Registered: 22-12-2006
Location: Barad-Dur, Mordor
Member Is Offline

Mood: metastable

[*] posted on 21-12-2008 at 03:29


I attached a jpg file yesterday without difficulty

I just converted same file to GIF in ACDSee and am attempting to post it below. Let's see what happens

Images uploaded without error and appears normal on my screen.

Better rethink your problem, John.

Because the forum s'ware seems to be working fine in this regard.

[Edited on 21-12-2008 by Sauron]

3-7584.gif - 5kB




Sic gorgeamus a los subjectatus nunc.
View user's profile View All Posts By User
not_important
International Hazard
*****




Posts: 3873
Registered: 21-7-2006
Member Is Offline

Mood: No Mood

[*] posted on 21-12-2008 at 05:47


Quote:
Originally posted by JohnWW
I have found today that, again, it is not possible to post image attachments to messages, even after repeated attempts with changes in the file-name.


By messages do you mean ordinary posts? I've attached GIFs, JPEGs, PNGs, and PDFs in the last several weeks without trouble.
View user's profile View All Posts By User

  Go To Top